یه مشکل با flash cs5 - استفاده از tlf برای نوشتن فارسی

شروع موضوع توسط oonjaweb ‏31 اکتبر 2010 در انجمن Action Script 3

کلمات کلیدی:
  1. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    سلام
    من در تعجبم تاحالا 2بار این اتفاق برام افتاده هر وقت از Tlf استفاده می کنم و می خوام متن رو فارسی بنویسم همه چیز برای خودم درسته و نشون داده میشه تو سیستم خودم ...
    یعنی ببینید من از TLF استفاده می کنم به درستی و خوبی کاملا جواب می ده
    اما به محض اینکه ایمیل می کنم ... ! یا اینکه آپلود .. یا اصلا رو سیستم دیگه ای که ADOBE FLASH CS5 نداشته باشه اجرا می کنم میبینم همینطوری 5تا نقطه هی دارند رد میشند مثل " لودینگ " و اصلا اصلا هیچی جز این نمیاره ...

    حجم فایل SWF کاملا درسته .. اما نمیدونم این چـه شانسیه من دارم کـه اینطوری میشه .. با برنامه مریم کار می کنم همه چی درسته ها !!
    اما تا میام خودم می نویسم باعث میشه دیگه برنامم بالا نیاد .. یعنی فایل فلشم اجرا نمیشه تو سیستمی که فلش نصب نداره ( flash player نصب هست )...
    به نظرتون مشکل از کجاست ؟
    ممنون :rose:
     
    نوشته شده توسط oonjaweb در ‏31 اکتبر 2010
  2. BehrouzPc

    BehrouzPc پــــادشــاه فــلــــش

    ارسال‌ها:
    1,909
    تشکر شده:
    3,510
    امتیاز دستاورد:
    113
    خوب اگر فلش پلیر StandAlone روی سیستمی نباشد و فقط روی مرورگر فرد باشد می بایست با مرورگر مشاهده نماید
    توجه کنید که TLF بر روی فلش پلیرهای قدیمی که احتمالا روی سیستم دومی که تست کردید بوده جواب نمی دهد
    در صورتی که روی مرورگری مثل فایر فاکس پلاگین فلش پلیر نصب باشد ، می بایست فایل فلش بدون مشکل نمایش داده شود ، به نسخه فلش پلیر دقت نمایید
     
    نوشته شده توسط BehrouzPc در ‏31 اکتبر 2010
    ++Hadi++ از این پست تشکر کرده است.
  3. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    بسیار ممنون ، فلش پلیر نسخه 10 هستش ... !
    روی مرورگر هم نسخه 10 هست اما باز مشکل داره !
    روی سیستم خودم که نرم افزار فلش نصبه بی مشکلــه ...
    در ضمن گاهی اوقات کاملا رو هــــــــــــمه سیستم ها درسته
    اما دیشب 3 تا حرف به کار اضافه کــردم میبینم امروز باز ریخته بهم ... !!! و روی اون سیستم ها ( فلش پلیر 10 - بدون نرم افزار فلش ) جواب نمیده
     
    نوشته شده توسط oonjaweb در ‏31 اکتبر 2010
  4. BehrouzPc

    BehrouzPc پــــادشــاه فــلــــش

    ارسال‌ها:
    1,909
    تشکر شده:
    3,510
    امتیاز دستاورد:
    113
    احتمالا مشکل از جایی دیگر می باشد ، فایل خروجی نهایی به صورت swf دیگر وابستگی به فلش ندارد ، فقط فلش پلیر نیاز دارد
    شما روی سیستم دیگری هم که نرم افزار فلش داشته باشید تست کرده اید؟
    روی این که فونتی که احتمالا Embed نکرده باشید و... دقت نموده اید؟
    دیگر موارد را چک کنید ، این که به نرم افزار فلش ربطی ندارد را بنده 99.9 درصد تضمین می کنم... :wink:
     
    نوشته شده توسط BehrouzPc در ‏31 اکتبر 2010
  5. DaDaDooDoo

    DaDaDooDoo کاربر VIP

    ارسال‌ها:
    712
    تشکر شده:
    583
    امتیاز دستاورد:
    16
    وقتی از tlf استفاده می کنید یک فایل با فرمت SWZ با آیکون خاکستری رنگ کنار فایل FLA ایجاد می شه ، اون باید کنار فایل SWF باشه .
     
    نوشته شده توسط DaDaDooDoo در ‏1 نوامبر 2010
    ++Hadi++ و m_zaidabadi از این پست تشکر کرده اند.
  6. ++Hadi++

    ++Hadi++ Active Member

    ارسال‌ها:
    3,529
    تشکر شده:
    5,801
    امتیاز دستاورد:
    36
    فقط چون فونتات Embed نیست ... چاره کار embed کردن فونتهاست ...باید فونت تمامی تکست فیلدات از نوعی باشه که در اون یه سری کاراکتر های خاص embed شده باشن و برا embed هم باید از پنل properties دکمه embed رو بزنی و کاراکتر ها رو انتخاب کنی .
    بای...
     
    نوشته شده توسط ++Hadi++ در ‏1 نوامبر 2010
  7. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    من از 2 فونت Calibri و 2 Mitra استفاده کردم ...
    یعنی باید برم تو embed و این ها رو اضافه کنم درسته ؟
    همین ؟
    الان من این کار رو انجام دادم اما باز 5 تا نقــطه .. البته فایل textLayout_1.0.0.595.swz هم کنارش قرار دادم و رو اون سیستمی که فلش پلیر 10 داره اما نرم افزار فلش روش نصب نیست تست کــردم و مـــــتاسفــــــــــانه اجرا نشد.
    کار من الان بیشتر از 300 خط تکست داره و شاید 30 تا تکست باکس
    حالا باید به نظرتون تک تک اینهارو embed کنم ؟ یه نفر لطفا دقیق و کاملتر راهنماییم کنه این کار اعصابم رو اونقدر خورد کرد که میگم صد رحمت به همون فارسی نویس مریم ... :snap::sad:
     
    نوشته شده توسط oonjaweb در ‏1 نوامبر 2010
  8. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    همه ی تکست هام رو چک کردم جز calibri و mitra نیست ... ! تو embed هم .. اضافه کردم عادی و Bold ش رو .. !!
    اما مشکل حل نشد .
     
    نوشته شده توسط oonjaweb در ‏1 نوامبر 2010
  9. ++Hadi++

    ++Hadi++ Active Member

    ارسال‌ها:
    3,529
    تشکر شده:
    5,801
    امتیاز دستاورد:
    36
    امشب یه سمپل می زارم... انشاءال...
     
    نوشته شده توسط ++Hadi++ در ‏1 نوامبر 2010
    m_zaidabadi از این پست تشکر کرده است.
  10. DaDaDooDoo

    DaDaDooDoo کاربر VIP

    ارسال‌ها:
    712
    تشکر شده:
    583
    امتیاز دستاورد:
    16
    شما از Document Class استفاده کردی ؟؟؟
     
    نوشته شده توسط DaDaDooDoo در ‏1 نوامبر 2010
    khalilonline از این پست تشکر کرده است.
  11. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    نه خیر.. !
    من کار دیگه ای رو باز می کنم و انجام می دم مشکلی پیش نمیادا
    اما این نمیدونم چـــه مرگشه ...!!
    توضیح کافیه سیمبل زحمتت میشه.
     
    نوشته شده توسط oonjaweb در ‏1 نوامبر 2010
  12. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    دوستان عزیز ، چی شد ؟! خبری ازتون نیست ..
    مشکل من سرجاشـــه ...
    از Export نیست ؟ آقا یکی به دادم برسه ...
     
    نوشته شده توسط oonjaweb در ‏2 نوامبر 2010
  13. ++Hadi++

    ++Hadi++ Active Member

    ارسال‌ها:
    3,529
    تشکر شده:
    5,801
    امتیاز دستاورد:
    36
    اینم سمپل cs5 و tlf :
    دان کن ...
    بای...
     

    پیوست ها:

    • TLFSample.rar
      اندازه فایل:
      کیلوبایت 250.6
      نمایش ها:
      522
    نوشته شده توسط ++Hadi++ در ‏2 نوامبر 2010
    aminislami و oonjaweb از این پست تشکر کرده اند.
  14. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    ممنون دستتــون درد نـکنه !
    حالا این به جز قضیه اکشن اسکریپتش ... میشه تو خود تکست نوشت ؟
    اگر روی Animation بذاریم متن رو Selectable هم اگــرنـباشه ... و فقط Embed کنیم فونت هامون رو کافیه ؟ درسته ؟!
    امروز تست کردم با حالت Animation و right to left گذاشــتم درست شد .
    میشه توضیحی هم بفرمائید ؟
     
    نوشته شده توسط oonjaweb در ‏2 نوامبر 2010
  15. ++Hadi++

    ++Hadi++ Active Member

    ارسال‌ها:
    3,529
    تشکر شده:
    5,801
    امتیاز دستاورد:
    36
    بله می شه ولی این راه بهترین و مطمئن ترینه ... من خودم به کد نویسی مسلط ترم و ترجیح می دم همه چی رو با کد درست کنم تا با دست . البته نه همیشه همیشه ...
     
    نوشته شده توسط ++Hadi++ در ‏2 نوامبر 2010
  16. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    خب میشه لطف بفرمائید یکم توضیح بدید ...
    مثلا چی کار کردید ... از اول
    و منظورتون از هر خط کد چی بود و دلیلش چیه و اینا.. !
    ممنــون!
     
    نوشته شده توسط oonjaweb در ‏3 نوامبر 2010
  17. ++Hadi++

    ++Hadi++ Active Member

    ارسال‌ها:
    3,529
    تشکر شده:
    5,801
    امتیاز دستاورد:
    36
    اول تو پنل library رو فلش بالا سمت راست کلیک کردیم و گزینه new font رو زدیم و یه شی فونت رو با اسمی خاص درست کردیم و نوع فونتو تعیین و در قسمت export for action script اونو برا استفاده مستقیم در اکشن با اسم کلاسی خاص export کردیم .سپس در قسمت embed font اون به نسبت نیازتون کاراکتر های مورد نیاز رو با زدن تیک embed میکنین . بعد تو کد نویسی یه شی از نوع فرمت متن بوجود آوردیم و همه پارامتر های اونو تنظیم کردیم و بعد یه شی از نوع فونتی که درست کردیم با اسم class name که در هنگام export کردن در فیلد class name نوشتیم رو بوجود می یاریم و فونت فرمتمونو مساوی نام فونت این فونت قرار می دیم و در نهایت فرمت اصلی تکست فیلد رو برابر با این شی فرمت قرار می دیم . بیشتر از این توضیح دیگه نمی تونم بنویسم .در امضام یه آموزش در مورد ورود اطلاعات فارسی از ایکسمل به فلش رو نوشتم که البته قدیمی هست و برا فارسی استایل هست و در اون به صورت کامل طریقه embed کردن فونتو نوشتم .
    موفق باشید ...
     
    نوشته شده توسط ++Hadi++ در ‏3 نوامبر 2010
    ultra1383 از این پست تشکر کرده است.
  18. hamidreza68504

    hamidreza68504 Member

    ارسال‌ها:
    154
    تشکر شده:
    49
    امتیاز دستاورد:
    16
    منم همچین مشکلی دارم تو وب . من لودینگ می سام وقتی از tlf هش استفاده کرده باشم اون 5 تا نقطه میاد . اگرم از مریم استفاده کنم همه چیز درسته
     
    نوشته شده توسط hamidreza68504 در ‏4 نوامبر 2010
  19. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    سلام ، دقیقا مشکل همینه عزیز
    شما تو library این پروژه ات .. فونتی که Embed کردی هست یا نه ؟
    اگــر نباشه باید فونت رو embed کنی...! تو پاسخ های بالا طرز این کار نوشته شده.:rose:
     
    نوشته شده توسط oonjaweb در ‏6 نوامبر 2010
  20. oonjaweb

    oonjaweb Active Member

    ارسال‌ها:
    120
    تشکر شده:
    28
    امتیاز دستاورد:
    28
    چه جالب ، تمام این کار ها رو انجام دادم ... مشکل درپروژه قبلیم پابرجاست ...
    روی یک سری سیستم ها مشکل داره .... به نظرتون چــرا ؟!
     
    نوشته شده توسط oonjaweb در ‏11 نوامبر 2010

به اشتراک بگذارید