مشكل با wamp

شروع موضوع توسط ULFSoft ‏12 مارس 2008 در انجمن برنامه‌نویسی با PHP

  1. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    سلام
    من امروز اين برنامه‌ي Wamp رو دانلود كردم. نصبش كردم. وقتي خواستم برم تو localhost ازم يوزر و پسورد خواست.
    گشتم، چند جا نوشته بود كه يوزرش root و پسوردش هم خاليه (blank). ولي اين رو از من قبول نمي‌كنه.
    نمي‌دونم چي كار كنم. هر چي هم سرچ كردم چيزي پيدا نكردم. اگه كسي مي‌دونه ايراد از چيه ممنون ميشم، راهنماييم كنه.

    من ويندوز xp sp2 دارم. اين نسخه از برنامه رو هم دانلود كردم : WampServer2.0b

    :sad:
     
    نوشته شده توسط ULFSoft در ‏12 مارس 2008
  2. milads

    milads Banned

    ارسال‌ها:
    483
    تشکر شده:
    263
    امتیاز دستاورد:
    16
    شما از xampp استفاده کن . راحت تری که .

    wamp خیلی مشکلات داره .
    موفق باشی .
     
    نوشته شده توسط milads در ‏12 مارس 2008
  3. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    آقا من تونستم مشكلشو حل كنم. به خاطر اين بود كه default browser رو موقع نصب opera انتخاب كرده‌بودم.
    الآن دوباره نصب كردم. گذاشتم رو ie درست شد.

    ولي الآن وقتي مي‌خوام برم phpmyadmin هيچي نمياره. چي كار كنم؟

    فرق اين دو تا چيه؟
    ارزش داره دانلود كنم؟
    از ديشب بيدارم، مي‌خوام روي localhost اسكريپت php اجرا كنم، ولي هر بار يه چيزي ميشه.
    اول فايل‌هاي php 5.2.5 رو دانلود كردم، نتونستم نصبش كنم.
    بعد رفتم installer ش دانلود كردم. با اون هم نشد.
    بعد اين wamp رو دانلود كردم، با اين هم نتونستم كار كنم.
    بعد كلي گشتم آموزش نصب php5 رو روي IIS پيدا كردم. مرحله به مرحله رفتم جلو، آخرش اجرا شد، ولي از همه‌ي صفحات php ارور ميگرفت.
    بعد دوباره اون installer رو نصب كردم، درست شد. ولي مي‌خواستم ديتابيس درست كنم، ديدم بايد برم بازم يه چيز ديگه دانلود كنم.
    الآنم كه اين wamp رو تونستم با موفقيت نصب كنم. اينجوريه.

    والا ديگه نمي‌دونم چي‌كار كنم؟
    مثلا مي‌خواستم اسكريپت‌ها رو localhost تست كنم كه وقتم هدر نره. اگه رو سرور آپ كرده بودم. تا الآن به نتيجه رسيده بودم.

    ما بريم اين xampp رو هم دانلود كنيم، ببينيم چيه؟

    ممنون
     
    نوشته شده توسط ULFSoft در ‏12 مارس 2008
  4. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    من الآن دارم xampp-win32-1.6.6a-installer.exe رو دانلود مي‌كنم. درسته؟
    يا بايد چيزه ديگه‌اي رو دانلود كنم؟
     
    نوشته شده توسط ULFSoft در ‏12 مارس 2008
  5. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    دانلود كردم. نصبشم كردم.
    ولي وقتي ميرم روي mysql يه پنجره باز ميشه و روي اون يه cmd باز ميشه و بعد جفتشون بسته ميشن.
    موقع نصب هم، براي نصب سرور apache اومد پورت‌ها رو چك كنه، كه گفت پورت 80 اشغاله و نتونست اونو نصب كنه.

    من برم رو سرور آپ كنم، سنگين تره.
    مثل اينكه شانس با ما يار نيست.
     
    نوشته شده توسط ULFSoft در ‏12 مارس 2008
  6. milads

    milads Banned

    ارسال‌ها:
    483
    تشکر شده:
    263
    امتیاز دستاورد:
    16
    عزیز باید قبلش wamp رو unistall کنی ها .
     
    نوشته شده توسط milads در ‏12 مارس 2008
  7. mohammad_molana

    mohammad_molana Member

    ارسال‌ها:
    232
    تشکر شده:
    356
    امتیاز دستاورد:
    16
    مثلا چه مشکلاتی؟؟؟؟

    به نظر من بهتره یه ویندوز عوض کنی و بلافاصله wamp رو نصب کن. نیازی به IIS و .... نداری.

    wamp5 خودش همه چی هستش.
     
    نوشته شده توسط mohammad_molana در ‏13 مارس 2008
  8. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    در اون حد می فهمم که باید قبلش اون رو unistall کنم.

    من که با هیچ کدومش نتونستن کار کنم.
    البته الآن رو سیستمم می تونم فایل های php رو اجرا کنم ولی mysql ...
     
    نوشته شده توسط ULFSoft در ‏13 مارس 2008
  9. jhoseini

    jhoseini Member

    ارسال‌ها:
    783
    تشکر شده:
    286
    امتیاز دستاورد:
    16
    iis رو خاموش کنید
     
    نوشته شده توسط jhoseini در ‏13 مارس 2008
  10. mohammad_molana

    mohammad_molana Member

    ارسال‌ها:
    232
    تشکر شده:
    356
    امتیاز دستاورد:
    16
    iis که ربطی به mysql نداره.
    اگه اون ران باشه، آپاچی غیر فعال می شه.

    آیا sqlServer نصب کردین؟

    اگه نصب کردین یا پاکش کنید یا برین از کنترل پنل - ادمین تولز - سرویسز sql رو stop کنید و wampsql رو run کنید
     
    نوشته شده توسط mohammad_molana در ‏13 مارس 2008
  11. hidensoft

    hidensoft Member

    ارسال‌ها:
    604
    تشکر شده:
    378
    امتیاز دستاورد:
    16
    WAMP هیچ کدوم از مشکلاتی که شما گفتین رو نداره ، مشکل یا از ویندوز هست یا نرم افزار هایی که روش نسبه ، شاید شما یه ویروس اسکن یا فایر وال داشته باشید که هم پورت 3363 Mysql و 80 اپاچی رو بسته باشه .
     
    نوشته شده توسط hidensoft در ‏13 مارس 2008
  12. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    آره sqlserver دارم. الآن stop كردمش. تست ميكنم.

    نچ. تغييري نكرد.

    در ضمن iis كه سهله. من هر چي رو سيستم مربوط به سرور و ... بود پاك كردم. الآن فقط يه wamp2 دارم.
    ولي الآن ديگه وارد localhost هم نمي‌تونم بشم. چه برسه به mysql. وقتي مي‌زنم localhost ، مرورگرم باز مي‌شه، بعد شروع مي‌كنه به لود كردن. اونم لودي كه هرگز تموم نميشه.

    يه چيزه ديگم هست. وقتي مي‌خوام برم تو mySQL Console يه cmd باز ميشه. ميگه Enter Password ، هنوز كه پسورد براش ست نكردم، پس اينتر رو مي‌زنم، بعد يه ارور مي‌ده و بسته ميشه.

    در ضمن فايروالم آفه. ويروس اسكنرم هم NOD32 هستش. اشكالي ايجاد مي‌كنه؟

    تو رو خدا بگيد من چي كار كنم.
     
    نوشته شده توسط ULFSoft در ‏14 مارس 2008
  13. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    اگه من بخوام خود php رو نصب كنم. بايد چي كار كنم؟
    من سري قبل فايل installer رو از سايت سورس فورج دانلود كردم. بعد نصب كردم. براي اجراي mysql نصب فقط اين كافيه؟
    يا نه؟ بايد چيزه ديگه‌اي رو هم دانلود كنم و نصب كنم؟

    ممنون ميشم، راهنماييم كنيد. اينجوري فكر كنم خيلي راحت تره.
    در ضمن من فقط يه Sqlserver يادم رفته بود، كه اون رو هم الآن به طور كامل پاكش كردم.
     
    نوشته شده توسط ULFSoft در ‏14 مارس 2008
  14. hidensoft

    hidensoft Member

    ارسال‌ها:
    604
    تشکر شده:
    378
    امتیاز دستاورد:
    16
    شما که WAMP,XAMP رو امتحان کردی ، EasyPHP رو هم توی کامپیوترت امتحان کن. شاید یه فرجی شد.
     
    نوشته شده توسط hidensoft در ‏14 مارس 2008
  15. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    ايراد از همون پورت 80 هستش. چون تا باز نشه apache نصب نميشه.
    اگه كسي مي‌دونه چطوري مي‌تونم بازش كنم، لطف كنه بگه. يا اينه بفهمم چه برنامه‌اي اين پورت رو اشغال كرده.

    فعلا كه دارم mysql رو دانلود مي‌كنم. اگه نشد، چشم، اين يكي رو هم مي‌گيرم نصب مي‌كنم. ممنون.
     
    نوشته شده توسط ULFSoft در ‏14 مارس 2008
  16. mohammad_molana

    mohammad_molana Member

    ارسال‌ها:
    232
    تشکر شده:
    356
    امتیاز دستاورد:
    16
    به نظر من بهتره نیم ساعت وقت بزاری و یه ویندوز نصب کنی.
    و بعد از نصب برنامه های اضافی خودداری کنی.
     
    نوشته شده توسط mohammad_molana در ‏14 مارس 2008
  17. hidensoft

    hidensoft Member

    ارسال‌ها:
    604
    تشکر شده:
    378
    امتیاز دستاورد:
    16
    همون طور که بهت گفتم به طور معمول آنتی ویروس و فایر وال ها پورت های ویندوز رو می بندند . تا حالا ندیدم نرم افزار دیگه ای اینکارو بکنه
     
    نوشته شده توسط hidensoft در ‏14 مارس 2008
  18. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    خب چطوري مي‌تونم اين پورت رو باز كنم؟
    برنامه‌اي روشي چيزي داره؟

    نصب ويندوز نيم ساعت طول ميكشه. ولي نصب برنامه‌هاي جانبي كه روي سيستمم نصبه يه روز وقتم رو مي‌گيره.
    در ضمن حوصلش رو ندارم.

    آقا من mysql رو دانلود كردم. phpmyadmin رو هم همينطور.
    اول iis رو نصب كردم. بعد php5. بعد mysql و آخرش هم phpmyadmin رو.
    الآن فايل‌هاي php یو مي‌تونم اجرا كنم. ولي وقتي phpmyadmin رو اجرا مي‌كنم، ميگه mysql نصب نيست.
    بايد چيكار كنم؟
    براي نصب mysql من همه‌چيز رو حالت ديفالتش رو انتخاب كردم.
     
    نوشته شده توسط ULFSoft در ‏14 مارس 2008
  19. jhoseini

    jhoseini Member

    ارسال‌ها:
    783
    تشکر شده:
    286
    امتیاز دستاورد:
    16
    apache یا iis رو خاموش کنید
    mysql رو uninstall کنید
    wamp رو نصب کنید، فقط wamp رو
    نباید این زیاد سخت باشه:shock:
     
    نوشته شده توسط jhoseini در ‏14 مارس 2008
  20. ULFSoft

    ULFSoft Member

    ارسال‌ها:
    86
    تشکر شده:
    7
    امتیاز دستاورد:
    6
    تست كردم قبلا.
    جواب نداد.
    آقا ببينيد من وقتي مي‌خوام برم تو كنسول mysql. بعد از اين كه پسورد رو مي‌زنم. اين پيغام رو مي‌ده و بسته ميشه.

    اصلا اين mysql رو چه جوري ميشه فهميد اكتيوه يا نه؟ تو Systray كه چيزي نشون نمي‌ده. موقع تصب من فقط يه گزينه بود كه نوشته بود auto start رو تيك زدم.

    :sad: يعني چرا نميشه؟ اعصابم خورد شد. اه
     

    پیوست ها:

    • error.JPG
      error.JPG
      اندازه فایل:
      کیلوبایت 28
      نمایش ها:
      3
    آخرین ویرایش: ‏14 مارس 2008
    نوشته شده توسط ULFSoft در ‏14 مارس 2008

به اشتراک بگذارید