[MT] مشكل با ديتابيس

Satanysimp

Member
سلام:
من هر كاري ميكنم از ديتابيس ارور ميگيره. تا اونجا كه من ميدونم يوزر و پاسورد ديتابيس رو
درست وارد كردم!!!

اينم ارور:


Loading initial data into system...
An error occurred while loading data:


Bad ObjectDriver config: Your DataSource directory ('./db') does not exist.
 

Parham

Active Member
مشکل شما در نحوه آپلود فایل ها هستش ... یک بار دیگر به دقت فلدر هارا آپلود کنید ...
 

Parham

Active Member
بله این کار را انجام بده اگر باز هم مشکل بر خوردی ، مشخصات هاست خودتو بفرست تا برات نصب کنم ... در ضمن کدام نسخه MT را می‌خوای نصب کنی‌ ...
 

Satanysimp

Member
ممنون . همين آخرين نسخه كه فارسي شده. اگر دوباره اين ارور رو داد بايد چي كار كنم؟
اگه خودم نصب كنم بهتره حده اقل ياد ميگيريم چي به چيه.
اين ارور هم وقتي كه ميخوام mt-load.cgi رو بزنم مياد.
 

Parham

Active Member
اگر این مشکل دوباره ایجاد شد، این مشکل را میتونی‌ اینجوری حل کنی‌ شما باید یک دایرکتوری برای DataSourceخودت ایجاد کنی‌ با یک نام دلخواه که بهتر هستش db بذاری و در فایل mt-config.cgi تعریف کنی‌ و همچنین سطح دسترسی‌ به این پوشه هم باید 777 قرار بدی ... بعد از اینکه شما این فلدر را ایجاد کردی فایل mt-config.cgi توسط یک ویرایشگر باز کن و خط DataSource /path/to/database/directory # پیدا کن و علامت # از اول اون بردار ، و سپس بر روی هاست خودت آدرس را پیدا کن و جای این قرار بده مثلا /home/user/public_html/mt/db ... و فایل را ذخیره و آپلود کن ، امیدوارم که مشکلت حل بشه
 

Satanysimp

Member
خوب حالا همه چيز بهم ريخته. عكس سايت رو گذاشتم تا ببينيد.

بعد من تو قسمت تنظيمات چه كار كنم تا وقتي اسم سايت رو مينويسم صفحه اصلي سايت بياد؟

الان صفحه اصلي سايت من فقط فايل هاي كه رو هاست هست و يا فولدر هارو نشون ميده.
 

پیوست ها

  • 79.8 کیلوبایت بازدیدها: 6
آخرین ویرایش:

Parham

Active Member
خوب مشکل شما این هستش که فلدر Static را ایجاد نکردید ! باید آنرا در بیرون فلدر Cgi-bin ایجاد کنید و نام آنرا یک نام مثل mt-static قرار بدید ... حالا از میان فلدر هایی‌ که آپلود کردید فلدر docs و images و فایل styles.css را به درون این فلدر منتقل کنید حال باید فایل mt-config.cgi باز کنید و در خط StaticWebPath /mt-static/ آدرس را به آدرس Static خودتون تغییر بدید و اگر # هم داشت از اول این خط بر دارید ... امیدوارم که این بار هم مشکلت حل بشه
 

Parham

Active Member
خواهش می‌ کنم دوست عزیز ، خوشحالم که مشکلت حل شد ...
 

Satanysimp

Member
مرسي پرهام جان . بعد از يك عمر جون كندن تونستم درست حسابي نصب كنم.

فقط الان نميدونم چه كار كنم كه وقتي اسم سايت رو مينويسم صفحه اول وبلاگ بياد بالا.
ممنون ميشم اينم توضيح بدي.
 

Parham

Active Member
ببین دوست عزیز پس از اینکه وارد سیستم شودی و شناسه و رمز عبور خودتو عوض کردی در قسمت سمت چپ باید عنوان First Weblog را ببینید روی اون کلیک کن و تنظیمات اصلی‌ را در بخش Setting انجام بده ... مخصوصا آدرس سایت و آدرس بر روی سرور - اگر که از قبل تنظیم نشده - بعد از اون که همه تنظیمات را انجام دادی از قسمت سمت چپ بر روی Rebuild کلیک کن تا فایل های سیستم به طور خودکار ایجاد بشه ... و بعد از اون بدون مشکل میتونی‌ به سایت خودت وارد بشی‌ ...
 

جدیدترین ارسال ها

بالا