لطفا زودتر پاسخ دهید مشکل به کاربردن UTF-8 در asp

jaz1354

New Member
من یک فایل aspدارم که از UTF-8 استفاده کرده ام وآن فایل را نیز با UTF-8 ذخیره کرده ام امـــــا مشکل اینجا است
که وقتی می خواهد اطلاعات را از دیتابیس به من نمایش دهد فونها به صورت غیر قابل خواندن می شود(فقط عباراتی که از دیتابیس خوانده شده است)
 

m_ziba

Member
شما قبل اين قطعه کد رو اول صفحه ات اضافه کن:

کد:
session.codepage = 65001
 

YPY-Design

Member
jaz1354 گفت:
من یک فایل aspدارم که از UTF-8 استفاده کرده ام وآن فایل را نیز با UTF-8 ذخیره کرده ام امـــــا مشکل اینجا است
که وقتی می خواهد اطلاعات را از دیتابیس به من نمایش دهد فونها به صورت غیر قابل خواندن می شود(فقط عباراتی که از دیتابیس خوانده شده است)
اگر از Option Explicit استفاده میکنید کد زیر را مجع قرار بدید.
<%@ Language="VBScript" CodePage="65001"%>
 

desiran

Member
YPY-Design گفت:
اگر از Option Explicit استفاده میکنید کد زیر را مجع قرار بدید.
<%@ Language="VBScript" CodePage="65001"%>
من هم همچین مشکلی تویه یه کی از صفحاتم دارم . این کاری که شما گفتید انجام دادم ولی درست نشد.

من مشکلم دقیقا این هست که وقتی اطلاعات از دیتا بیس بیرون میاد تویه یه صفحه درست نمایش داده میشه تویه یک صفحه ی دیگه که تویه یه فولدر دیگست نا مفهوم هست و بیشتر حرف "ط" و "ز" توش داره :D . اگه می تونید کمکم کنید
 

YPY-Design

Member
desiran گفت:
من هم همچین مشکلی تویه یه کی از صفحاتم دارم . این کاری که شما گفتید انجام دادم ولی درست نشد.

من مشکلم دقیقا این هست که وقتی اطلاعات از دیتا بیس بیرون میاد تویه یه صفحه درست نمایش داده میشه تویه یک صفحه ی دیگه که تویه یه فولدر دیگست نا مفهوم هست و بیشتر حرف "ط" و "ز" توش داره :D . اگه می تونید کمکم کنید
یعنی شما هم از <% @ Language="VBScript" CodePage="65001"%> و هم از<META http-equiv="Content-Type" content="text/html; charset=utf-8"> استفاده کردید و درست نشد؟
 

desiran

Member
YPY-Design گفت:
یعنی شما هم از <% @ Language="VBScript" CodePage="65001"%> و هم از<META http-equiv="Content-Type" content="text/html; charset=utf-8"> استفاده کردید و درست نشد؟
نه درست نشد . همون مشکلی رو که داشتم برایتون نوشتم
حالا به نظرتون مشکلش چیه . من فکر کنم ویندوزه . چون رویه PC خودم درسته ولی رویه pc دیگه امتحان کردم درست نشد.
 

YPY-Design

Member
desiran گفت:
نه درست نشد . همون مشکلی رو که داشتم برایتون نوشتم
حالا به نظرتون مشکلش چیه . من فکر کنم ویندوزه . چون رویه PC خودم درسته ولی رویه pc دیگه امتحان کردم درست نشد.
خوب عزیز زود تر میگفتین... چون امکان نداره که با این دو خط کد مشکل فارسی نویسی حل نشه!
ولی در مورد سیستم دوستتون، یکی از پک های ماکروسافت هست که این مشکل رو داره. نمیدونم حالا پک 2 هست یا خیر. چون همینجوریش این سیستم عامل یه جورایی مادرزادی با فارسی مشکلاتی رو داره.
ولی فکر کنم با پک 1 مشکلی نداشته باشید.(ایکس پی).
در این مورد بیشتر از این کاری از دستم بر نمیاد. ولی میتونید دعا کنید تا درست بشه:)
موفق باشید.
 

جدیدترین ارسال ها

بالا