کمک

شروع موضوع توسط esk ‏15 نوامبر 2005 در انجمن برنامه‌نویسی با ASP.NET

  1. esk

    esk New Member

    ارسال‌ها:
    28
    تشکر شده:
    0
    امتیاز دستاورد:
    1
    دوست عزيز سلام از لطف شما متشكرم . با راهنمايي خوب شما سايتم درست شد ولي يك مشكل دارم و آن اينست كه تمامي فونتهاي آن بهم ريخته است و من از فونتهاي tohoma و arial استفاده كردم و در كامپيوتر خودم خوب كار مي كند ولي روي host اينطور نيست لطفا در اين مورد نيز مرا راهنمايي كنيد متشكرم:sad:
     
    نوشته شده توسط esk در ‏15 نوامبر 2005
  2. parsit

    parsit New Member

    ارسال‌ها:
    25
    تشکر شده:
    1
    امتیاز دستاورد:
    1
    از یونیکد utf-8 استفاده کردی؟
     
    نوشته شده توسط parsit در ‏15 نوامبر 2005
  3. amirlol

    amirlol Active Member

    ارسال‌ها:
    1,859
    تشکر شده:
    298
    امتیاز دستاورد:
    36
    چرا ند تا تاپیک جداگانه می زنی !!!!

    بستگی داره !!!!!!!
    استفاده کن نشد بگو
     
    نوشته شده توسط amirlol در ‏15 نوامبر 2005
  4. esk

    esk New Member

    ارسال‌ها:
    28
    تشکر شده:
    0
    امتیاز دستاورد:
    1
    كمك

    دوست عزيز سلام از لطف شما متشكرم از يونيكد استفاده كردم ولي جواب نگرفتم مشكلم دقيقا اين است كه تمامي جملات فارسي داخل سايت بصورت كد شده نشان مي دهد اين در صورتي است كه روي كامپيوتر من خوب نشان مي دهد
     
    نوشته شده توسط esk در ‏19 نوامبر 2005
  5. mosyhey

    mosyhey Member

    ارسال‌ها:
    313
    تشکر شده:
    116
    امتیاز دستاورد:
    16
    یعنی هم تمام جملات فارسی در صفحه ات را به صورت utf-8 درآورده ای و هم در سورس صفحه در تگ meta پارامتر charset را مساوی utf-8 قرار داده ای و هنوز هم نمی شود مطالب را درست دید ؟
    آیا هنگام مشاهده صفحه از منوی view مقدار encoding را utf-8 قرار داده ای ؟
    جواب این سه سوال را بده تا ببینیم مشکل چیست ؟ و اگر هر کدام از این سه مرحله هم توضیح بیشتر می خواهد بگو .
     
    نوشته شده توسط mosyhey در ‏19 نوامبر 2005
  6. esk

    esk New Member

    ارسال‌ها:
    28
    تشکر شده:
    0
    امتیاز دستاورد:
    1
    كمك

    دوست عزيز سلام من در سورس charset=utf-8 قرار دادم ولي حتي روي كامپيوتر خودم هم جواب نداد با اين حال upload كردم و جواب نداد و عجيب تر اين كه وقتي از روي اينتر نت اجرا كردم و از منوي view گزينه source نگاه كردم اين دو خطي كه در مورد charset=utf-8 نوشته بودم نديدم و من حتي چند بار upload كردم ولي جواب نگرفتم البته مقدار view را نيز به utf-8 تغيير دادم ولي نمي دانم منظور شما از تبديل جملات به utf-8 چيست لطفا كمي توضيح دهيد. متشكرم:sad:
     
    نوشته شده توسط esk در ‏19 نوامبر 2005
  7. mosyhey

    mosyhey Member

    ارسال‌ها:
    313
    تشکر شده:
    116
    امتیاز دستاورد:
    16
    با عرض سلام خدمت جناب esk
    موارد و مراحلي را مي گويم که با عمل به آن ها 90% وحتي 100% مشکل و معضل فارسي در وب حل مي شود .

    1 - حتي المقدور از ويندوز xp استفاده کنيد و توضيحات مربوط به اين ويندوز است .
    2 - فرض مي کنيم شما فايلي ايجاد کرده ايد باپسوند هاي htm , html , asp و .... که حاوي دستورات ، تگ هاي html و متون انگليسي و فارسي است . براي نوشتن جملات فارسي در اين فايل ها در ويندوز xp به راحتي زبان کامپيوتر را به فارسي "FA" تغيير دهيد و فارسي تايپ کنيد . اگر فارسي نداريد از کنترل پنل ويندوز در بخش language and regional option اين زبان را اضافه کنيد که توضيحش از اين بحث خارج است .
    3 - کار شما که تمام شد فايل را save کرده و آن را ببنديد .
    4 - حال بايستي اين فايل را تبديل به utf-8 کنيد . براي اين کار يک notepad را باز کنيد از بخش accessoies از منوي start
    5 - سپس آن فايل را که مي خواهيد يونيکد utf-8 کنيد را در آن notepad باز کنيد يعني يا آن فايل را بکشيد و در نوت پد اندازيد يا در نوت پد با استفاده از منوي file و دستور open اين کار را انجام دهيد .
    6 -الآن که محتويات آن فايل در آن نوت پد آمد ابتدا از منوي edit و دستور replace جاي همه "ی" ها را با "ي" (منظور shift+x) عوض کنيد . اين کار باعث مي شود متون فارسي شما در ويندوز 98 و ساير ويندوز هاي غير فارسي هم درست نشان داده شود و ی هاي ميان کلمات به صورت ی آخر نشان داده نشود .
    7 - سپس در نوت پد از منوي file دستور save را اجرا کنيد . در کادر باز شده در پايين ترين قسمت يعني در جلوي قسمت encoding مقدارش را برابر utf-8 کنيد و سپس کليد save را بفشاريد و نوت پد را ببنديد . حالا فايل شما يونيکد utf-8 شده است .
    8 - حال بايستي در فايل html خود تغييري دهيد و نحوه نمايش آن را utf-8 تعيين نماييد . بدین صورت که بایستی خط زیر را باید به داخل تگ head اضافه کنید . البته اگر این خط وجود دارد مقدار charset را utf-8 کنید .
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">​
    توجه داشته باش ممکن است " ها جابجا نشان داده شود . شما کل ای خط را copy کن و paste کن در محل مورد نظر .
    پس شمای کلی فایل html باید این جور با شد :
    <html>
    <head>
    <title>Untitled Document</title>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    </head>
    <body>
    </body>
    </html>​
    9 - در این هنگام فایل را save کرده و ببنديد . البته بهتر بود قبل از utf-8 کردن این کار را بکنیم که شما هم همین کار را بکنید .
    10 - کار تمام است فایل را آپلود کنید .
    11 - هنگام مشاهده صفحه روی مرورگر از منوی view مقدار encoding را utf-8 قرار دهید .
    12 - اگر می بینید هنوز متون فرقی نکرده و محتوای قبلی را دارید می بینید در مرورگر ctrl+F5 را فشار دهید تا سایت از روی کش نشان داده نشود و از سرور لود شود .

    امیدوارم درست شده باشد وگر نه فایلتان را برایم بفرستید تا ببینم مشکل چیست و اگر هم که درست شده همین جا آدرسش را بگذارید تا ما هم ببینیم .
     
    آخرین ویرایش: ‏19 نوامبر 2005
    نوشته شده توسط mosyhey در ‏19 نوامبر 2005
  8. amirlol

    amirlol Active Member

    ارسال‌ها:
    1,859
    تشکر شده:
    298
    امتیاز دستاورد:
    36
    حالا یه چیزی !!!!
    دیتابیس شما به احتمال 99درصد SQL است !!!!
    و احتمالآ سرور شما پیشفرض دیتابیس رو انگلیسی گذاشته
    <%@ codepage=65001%>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <meta http-equiv="Content-Language" content="fa">

    رو اول صفحه ات بزار ببین حل می شه یا نه
     
    نوشته شده توسط amirlol در ‏20 نوامبر 2005

به اشتراک بگذارید